Maikiwi Global Network - SSL/TLS Certificate Issuing – Incident details

All systems operational

SSL/TLS Certificate Issuing

Resolved
Major outage
Started 5 months agoLasted about 13 hours

Affected

Maikiwi (Global)

Partial outage from 2:02 PM to 2:49 PM, Operational from 2:49 PM to 2:34 AM

Certificate Authority (Internal)

Partial outage from 2:02 PM to 2:49 PM, Operational from 2:49 PM to 2:34 AM

Maikiwi (Services)

Major outage from 2:02 PM to 2:49 PM, Degraded performance from 2:02 PM to 2:49 PM, Operational from 2:49 PM to 2:34 AM

Aria

Major outage from 2:02 PM to 2:49 PM, Operational from 2:49 PM to 2:34 AM

Certificate Issuance

Major outage from 2:02 PM to 2:49 PM, Operational from 2:49 PM to 2:34 AM

Caesar Monitoring

Degraded performance from 2:02 PM to 2:49 PM, Operational from 2:49 PM to 2:34 AM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Monitoring
    Monitoring

    We have deployed a revision to our CA and a public ACME client as a fallback in case further issues occur. Since exponential backoff was observed for many endpoints, this incident will be continually monitored until the revised build has successfully reissued all active certificates.

  • Identified
    Identified
    We are continuing to work on a fix for this incident.
  • Investigating
    Update

    We are investigating a backlog of certificate signing requests that are failing internal challenges. This will impact all customer endpoints and Caesar sessions configured with 1-day expiration certificates.

  • Investigating
    Investigating

    We are currently investigating this incident.